Get Linux Distribution Name and Version and Kernel Version

Linux Distribution Name and Version

cat /etc/*-release

or

lsb_release -a

 

Kernel Version

uname -a

or

uname -mrs

Get IP address of the client in an SSH session

echo $SSH_CLIENT | awk '{ print $1}'
echo $SSH_CONNECTION | awk '{ print $1}'
who am i | awk '{print $5}' | sed 's/[()]//g'

Quersumme und einstellige Quersumme mit Excel bestimmen

Eine schöne und einfache möglichkeit die Quersumme mit Excel zu bestimmen ist wie folgt:

=SUMMENPRODUKT(WERT(TEIL(A1;ZEILE(INDIREKT("A1:A"&LÄNGE(A1)));1))*1)

 

Wer die einstellige Quersumme sucht, kann die Formel verwenden:

=(REST(A1-KÜRZEN(A1/9)*9;-9)+9)*(A1>0)

Buchstabenwert mir Excel bestimmen

Eine schöne und einfache möglichkeit den Buchstabenwert mit Excel zu bestimmen ist wie folgt:

=CODE(GROSS(A1))-64

Gern auch in der Kombination mit einer Prüfung:

=WENN(ISTLEER(A1);"";CODE(GROSS(A1))-64)

Ist der Buchstabenwortwert gefragt, so hilft die Formel weiter:

=SUMMENPRODUKT(CODE(TEIL(GROSS(A1);ZEILE(INDIREKT("1:"&LÄNGE(A1)));1))-64)

Raspberry pi 24/7 Betrieb

http://www.kuemmel-digital.com/?p=367

ddclient auf einer AWS EC2 instance

Installation von ddclient:

sudo apt-get update && sudo apt-get upgrade -y
sudo apt-get install -y ddclient

Während der installation die Werte aus ddclient.conf eintragen.
Config File: /etc/ddclient.conf:

protocol=noip
use=web, web=http://169.254.169.254/latest/meta-data/public-ipv4
server=dynupdate.no-ip.com
login=<login>
password='password'
hostname.no-ip.org

ddclient Config /etc/default/ddclient

run_ipup="false"
run_daemon="true"

Und dann den Dienst neu starten.

sudo service ddclient restart

DIY Beton

DIY-Beton-Dekohaus

Weihnachtshäuschen aus Beton

Tannenbaum Magnete

Diamanten

Kerzenständer

Und noch die Sammlung

Vasen

Oh, Beton!

Zement Häuser

 

 

Regex für Koordinaten

Hilfe bei RegEx:

http://txt2re.com/
http://www.regexr.com/
https://regex101.com/
http://www.regular-expressions.info/

Für die Nord/Süd-Koordinate:
(N|S|n|s)(.)([0-9]|[0-8][0-9]|90)(. )([0-5][0-9]|[0-9])(\.)(\d{3})

Für die West/Ost-Koordinate:
(W|E|O|w|e|o)(.)([0-9]|[0-9][0-9]|0[0-9][0-9]|[0-1][0-7][0-9]|180)(. )([0-5][0-9]|[0-9])(\.)(\d{3})

Byobu – Funktionstasten ohne Funktion in Kombination mit Putty

Wer Byobu auf seinem System verwendet und die Verbindung mit Putty aufbaut wird feststellen das die Funktionstasten (wie F2, F3 und F6) nicht funktionieren. Dieses Problem wird dadurch verursacht, dass die Sequenzen für die Funktionstasten von Putty nicht so schickt wie sie von Byobu erwartet werden. Dies kann jedoch leicht in Putty behoben werden.

Einfach die Session laden und unter dem Menüpunkt Connection -> Data den Wert für Terminal-type string in „putty-256color“ ändern.
Dann sie Session wieder abspeichern und wie gewohnt verwenden. Nun funktionieren auch alle Funktionstasten wie gewohnt.

Sollte es dann immer noch nicht gehen, kann möglicherweise noch ncurses-term installiert werden.

sudo apt-get install ncurses-term

Byobu als Terminalmultiplexer

Byobu ist ein Programm, das das Leben auf der Console einfach macht. Byobu baut auf GNU Screen auf und ist ein Terminalmultiplexer. Praktisch ein  Fenstersystem für Konsolenprogramme.

Byobu erlaubt es viele Konsolen Fenster oder Programme zur gleichen Zeit laufen zu lassen.


Einfach mal installieren und testen. Mit F1 kommt ihr nach dem start von byobu in das Konfiguration Menu.

sudo apt-get update && sudo apt-get upgrade -y
sudo apt-get install -y byobu