Archive for the Geocaching Category

Quersumme und einstellige Quersumme mit Excel bestimmen

Eine schöne und einfache möglichkeit die Quersumme mit Excel zu bestimmen ist wie folgt:

=SUMMENPRODUKT(WERT(TEIL(A1;ZEILE(INDIREKT("A1:A"&LÄNGE(A1)));1))*1)

 

Wer die einstellige Quersumme sucht, kann die Formel verwenden:

=(REST(A1-KÜRZEN(A1/9)*9;-9)+9)*(A1>0)

Buchstabenwert mir Excel bestimmen

Eine schöne und einfache möglichkeit den Buchstabenwert mit Excel zu bestimmen ist wie folgt:

=CODE(GROSS(A1))-64

Gern auch in der Kombination mit einer Prüfung:

=WENN(ISTLEER(A1);"";CODE(GROSS(A1))-64)

Ist der Buchstabenwortwert gefragt, so hilft die Formel weiter:

=SUMMENPRODUKT(CODE(TEIL(GROSS(A1);ZEILE(INDIREKT("1:"&LÄNGE(A1)));1))-64)

Regex für Koordinaten

Hilfe bei RegEx:

http://txt2re.com/
http://www.regexr.com/
https://regex101.com/
http://www.regular-expressions.info/

Für die Nord/Süd-Koordinate:
(N|S|n|s)(.)([0-9]|[0-8][0-9]|90)(. )([0-5][0-9]|[0-9])(\.)(\d{3})

Für die West/Ost-Koordinate:
(W|E|O|w|e|o)(.)([0-9]|[0-9][0-9]|0[0-9][0-9]|[0-1][0-7][0-9]|180)(. )([0-5][0-9]|[0-9])(\.)(\d{3})

PqDL auf dem Raspberry

Wer seine Pocket Querys immer schön automatisch runterladen möchte um sie dann Bespielsweise in GSAK zu importieren, dem kann ich nur PQDL empfehlen.
Hierbei handelt es sich um ein Python Script, welches unter Windows wie auch unter Linux läuft.
Entwickelt wurde es von leoluk. Eine Dokumentation findet ihr auf seiner Seite.

 

Hier nun die Installation auf dem Raspberry:

Erst mal pqdl herunter laden und ausführbar machen

wget https://pqdl.svn.sourceforge.net/svnroot/pqdl/trunk/pqdl.py
chmod +x ./pqdl.py

Dann die fehlenden Pakete installieren

sudo apt-get install -y python-mechanize python-beautifulsoup python-colorama

Dann lassen wir es mal laufen….

./pqdl.py -u NICKNAME -p "DEIN_PASSWORT" --loginsecure --delay --journal

Unter Windows ist es noch einfacher. Hierfür auf der Seite einfach die Windows Version runter laden und gut ist.

Wer will, dass die Pocket Querys automatisch heruntergeladen werden legt sich nun noch einen cronjob an:

crontab -e
0     8-18,20-22   * * *     ./pqdl.py -u NICKNAME -p "DEIN_PASSWORT" --loginsecure --delay --journal -o /home/EIN_ORDNER_DEINER_WAHL/pq/ > /dev/null

Nun wird immer zwischen 8:00 – 18:00 Uhr und 20:00 – 22:00 geprüft ob neue PQs vorhanden sind und wenn ja runtergeladen und in dem Ordner EIN_ORDNER_DEINER_WAHL gespeichert.